Unable to type left parenthesis?

With the update to PyCharm Community Edition 2016.1, for some strange reason I've lost the ability to type a left parenthesis, but only when the cursor is next to text...ie: on a blank line, or with a space between the text I can type it. 

Example: def look_for_sim() <--- I can't type that in the IDE, the left parens "(" cannot be typed since it's next to other text. 

I made sure to disable any custom plugins not bundled with PyCharm, but still....

I'm tearing my hair out here. WTF changed with the new update that would cause this for me? A search turns up nothing remotely connected, so I'm stumped. And being able to type ( is pretty important.

10 comments
Comment actions Permalink

I have the Same problem, but only on OSX so far (I think it did not occur on linux, I'll check tonight)

0
Comment actions Permalink

i have this problem as well on osx

0
Comment actions Permalink

It's September 2019, and I'm encountering this problem.  Has it ever been resolved?

0
Comment actions Permalink

I'm having this issue as well.  Very specifically, it only happens when I am adding a method to a class. Works fine if the method isn't part of a class, and like the original poster, it works if I add a space after the method name.  I'm on macOS with IntelliJ version IU-192.6817.14.  Such a minor problem but super annoying!

0
Comment actions Permalink

I am having this problem in Pycharm on Win10 - first time it happened is today. Can't type "(", in the python console, and it's not the keyboard....

0
Comment actions Permalink

Hi Bradley, couple of questions if you don't mind:

- What is your IDE version? Do you have this issue in the latest one?

- What is your keyboard layout?

 

0
Comment actions Permalink

I have been experiencing the same problem. Left parenthesis "(" is not working for me.

the IDE version is:

PyCharm 2019.3.1 (Community Edition)
Build #PC-193.5662.61, built on December 18, 2019
Runtime version: 11.0.5+10-b520.17 amd64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Windows 10 10.0
GC: ParNew, ConcurrentMarkSweep
Memory: 972M
Cores: 4
Registry:
Non-Bundled Plugins: com.kite.intellij, com.thvardhan.gradianto

the keyboard layout is: US QWERTY

 

 

 

 

 

0
Comment actions Permalink

@ sh.alnazarov

Can you please try disabling custom plugins, and if that doesn't help, submit an issue to https://youtrack.jetbrains.com/issues , providing IDE logs (https://intellij-support.jetbrains.com/hc/en-us/articles/207241085-Locating-IDE-log-files)

0
Comment actions Permalink

Andrey Resler, it worked. Thank you so much!  Can you please advise on why it is strongly recommended not to use Kite plugin in Pycharm cause it's very useful for smart completion of code?

0
Comment actions Permalink

It's not that it's "not recommended". Kite is a third-party plugin, it's not developed by us. If the issue is caused by a third-partly plugin, it should be resolved on their side. 

https://help.kite.com/

0

Please sign in to leave a comment.