Slow 'Loading CMake project...' on each CLion run

I'm trying to edit a large (more than several GBs) project with CLion 2016.1.1, however each time when I load the stuff it takes more than one hour in order for this process to complete. All that time I barely can work because my i3 CPU is 100% occupied.

Is it possible to make CLion to save the results of that process in order to run faster on next start? I have tried clicking 'Save all' just after it completed, but no luck.

Thanks

1 comment

Hi Valentin.

Sorry for the delay! Could you please try enabling memory indicator (Preferences | Appearance & Behavior | Appearance | Show memory indicator) and keep an eye on it for some time. If it is close to the limit at the time when you are experiencing the problems, then try increasing the Xmx JVM option according to this guide. Does that help?

If it does not help, please capture a CPU snapshot so we can take a look at what is going on and upload it to our ftp which is mentioned in the article.

0

Please sign in to leave a comment.