What are the gotchas with using MinGW-w64 5.3.0 posix seh with CLion 2016.1.1?

I prefer to stay with the current versions of the toolchain.  So that means with this version of MinGW-w64 I'm using GDB 7.10.1 and MinGW-w64 5.x.  I know those aren't supported but they seem to work (so far).

So 3 questions:

  1. Is anyone on the latest toolchain and if so have you had any issues?
  2. Has JetBrains done any testing with the latest toolchain and if so what have you found?
  3. When does JetBrains plan on reving the supported MinGW-w64 version?

 

Thanks.

1 comment

Hi!

As you may know we don't support GDB higher then 7.8 version and this is the main reason why we don't support latest MinGW-w64 distributions. So as for compilers, CMake, libraries etc versions we don't have any limitations, our language support based on language standards, if you encounter any issues with parsing/resolve in code etc - feel free to submit bugs or search for existing one and vote for it https://youtrack.jetbrains.com/issues/CPP.

Regarding GDB support, we're analysing upgrade to 7.11 version (CPP-3311), hope we'll be able to support it soon along with latest MinGW-w64.

0

Please sign in to leave a comment.