Status and where's the source?

Hi,

obviously the clojure plugin for IntelliJ IDEA is not working with Maia (Version 9). There haven't been updates for months and I was wondering if we will see any updates in the near future?

I think the now free IntelliJ IDEA Community Edition would be a great environments to use with clojure... time to fix the plugin :-)

I thought about compiling and maybe fixing the plugin but the official source URL (http://svn.jetbrains.org/idea/Trunk/clojure-plugin) now redirects to jetbrains.com

Best regards,
Stefan

11 comments

After some more digging around I found the source now in the git repository:

     git://git.jetbrains.org/idea/clojure-plugin.git

-Stefan

0

Hi, Stefan.

This is exactly what I was going to announce in these days. As you may notice, the updated plugin version is uploaded into plugin repository and we are about to resume work on the plugin.

With best regards,
Ilya

0

I am unable to clone the Git repository:

git clone git://git.jetbrains.org/idea/clojure-plugin.git
Initialized empty Git repository in /<path>/.git/
fatal: The remote end hung up unexpectedly


Main IDEA repository seems to work fine (git clone git://git.jetbrains.org/idea/community.git idea).

Any idea what could be wrong?

Thanks,
/Patrik

0

I've got the source from Git but am having some trouble getting it to build. I'm using Java 1.6 and Idea 8.1.3, is this a supported combination or has development moved on to the 9.0 plugin API already?

So far I've added the following Jars to the class path to resolve most of the class/symbol not found errors: annotations, idea, jdom, openapi, util (all from the Idea lib folder). I'm still getting a few class not founds but can't locate the corresponding classes, for example: com.intellij.codeInsight.completion.CompletionContributorEP, PsiQualifiedNamedElement.

Is there any chance somebody could write up a quick how-to guide for getting this plugin to build, or if I'm using the wrong build environments could somebody point me in the direction of the correct versions?

Cheers,
Ian.

0

OK, I think that I'm almost there, albeit probably not in a very clean manner! It looks like the code has been migrated to the 9.0 API so I've downloaded an EAP build. Right off the bat there are a couple of issues:

1. I can't use the 9.0 build to develop with as it doesn't understand plugin modules, it also won't let me create a "Idea SDK" type JDK, when I go to add a new JDK instead of giving me the little "add new JDK" popup with a list of JDK types it just takes me straight to the "select home" dialog.

2. no problem, I can just go ahead an keep working in 8.1.3, so I got rid of the library entry that I was using and replaced it with one pointing at the Maia jars (idea, openapi, &c.). I also had to add extensions and junit-4.6 to the list to resolve all of the symbols.

However, now when I try to build the plugin I get an error that reads "Wrong jdk type for plugin module 'clojure-plugin'". Fair enough, as I've got it set up with a regular Java 1.6 JDK - I'm running snow leopard and that is the only java version available - the 1.5, 1.4 and so on java frameworks are really java 1.6, see:

ians-mbp:lib ianp$ /System/Library/Frameworks/JavaVM.framework/Versions/1.5/Home/bin/java -version

java version "1.6.0_15"

Java(TM) SE Runtime Environment (build 1.6.0_15-b03-219)

Java HotSpot(TM) 64-Bit Server VM (build 14.1-b02-90, mixed mode)



As a result, if I try to add an idea SDK using the Maia build that I downloaded I get "No Java SDK of appropriate version found. In addition to the IDEA JDK, you need to define a JSDK with the same Java version (1.5)."

So: is there a way to build this on Mac OS X Snow Leopard (i.e. with Java 6)?
0

Ilya,

thanks and continue the great work!
However, the plug-in refuses to load with current Maia builds. I tried today with IU-90.137 and La Clojure 0.2.159 and it fails silently. No hint in Idea's log file. After installing and restarting, the plug-in is deactivated and colored red in the plug-in view. Any ideas?

Best regards,
Stefan

0

Hi.

Due to some problems with plugin repository renewal we didn't upload the actula plugin build in time. Try to update it now, please.

Cheers!
Ilya

0

Hi, Ian.

The current development of La Clojure plugin sitcks with last versions of Maia EAP (IDEA 9). The point of inclusion of Devkit plugin (which allows to define IDEA SDK for plugin development) is still under discussion. To build the plugin as a plain module you should attach to your SDK all jars from the $IDEA_HOME/lib folder, including `idea.jar' but without plugins. To get through the message about the incompatible JDK, try to adjust the Internal Java platform combo-box in Project Settings -> SDKs -> IDEA SDK you use.

Regards,
Ilya

0

Great... now it works like a charm. Thanks, Ilya!

-Stefan

0

Hi Ilya,

Cool - got it (mostly) working now, thanks! including all of the libs from IU-90.137 did the trick, I think that my mistake was trying to use the compiled classes from the community edition source build that I've got here, I must have been missing a few thinks out.

I think including the dev kit (i.e. the IDEA SDK type) would be a good thing, not least because all of the existing getting started type documentation assumes that it's there.

Cheers,
Ian.

0

Very old thread, but its the only one coming up for "Wrong jdk type for plugin module"

Im trying to follow the instructions on this page:
http://confluence.jetbrains.net/display/IDEADEV/Creation+of+Tool+Windows

to get a 'toolWindow' working but hitting the error:

Wrong jdk type for plugin module 'toolWindow'.

using Intellij IDEA 11.1.1
Build #117.117

I've tried going to
"Open Module Settings" -> Module SDK -> set to the same as the other module settings "Project SDK"

but still the error.

I tried coping the internals and setting it up as a differnent module name, but cant seam to get a tool window to appear and show what the docs say its supposed to show.

Are there any step-by-step tutorials for the latest community version?

(The ultimate goal is to build a plugin that connects to the API of my site)  cant seam to get passed the first step of getting a tool window working though. :(

- - edit - -
The other way i try to get the tool window showing is to make a new 'module from scratch'  on a folder containing the sample /plugins/toolWindow  and add the toolWindow to the plugin.xml file that is created, but when i run it, IDEA does start witht the "Sample Calendar" toolWindow button, but there is nothing in there and there is an error:
7:41:26 PM ClassNotFoundException: myToolWindow.MyToolWindowFactory PluginClassLoader[Plugin name here, 1.0]: myToolWindow.MyToolWindowFactory PluginClassLoader[Plugin name here, 1.0]

0

Please sign in to leave a comment.