La Clojure and Intellij 10.5.2

I have La Clojure 0.4.9, and I'm trying it with Intellij 10.5.2.

In preferences -> plugins, it lists La Clojure in red and says it is not compatible with this version of Intellij (10.5.2).

When will 10.5.2 be supported?

And thanks for making this plugin available in the first place?

Marc

6 comments

Hi Marc.

Try to install the plugin via the plugin manager from IDEA: the IDEA 10.5.2 is supported by the plugin version 0.3.101.
The build 0.4.9 you have is supposed to work with Nika EAP.

Cheers,
Ilya

0

That worked. Although, I had to first delete the clojure-plugin directory from the plugins folder.

Thanks.

0

Is there any chance that the fixes in 0.4.* of the La Clojure plugin will be working in 10.5.2? I don't want to switch to IDEA 11 EAP at this point because I'm not in a position to use an unstable development environment. At the same time, I'd really like to use La Clojure, but the current plugin available for 10.5.2 breaks the IDE to an extent that makes it unusable for me.

0

Wait, I see that there's a newer version available on the repository site. This is not showing up in the list of available plugins from within IDEA, though. I tried just copying the Zip for 0.3.101 (10250) into the system\plugins folder, but La Clojure still shows up as not installed. What do I need to do to get this updated version installed?

0

Hello.

Ok, we have changed the requirements for the IDEA version compatibility.
PLease, check the plugin repository again.

Cheers,
Ilya

0

Ilya,

That did the trick, thanks a lot!

I also noticed that IDEA 11 makes it a lot easier to install downloaded plugins directly without going through a repository. That's a nice addition, I think.

OK, soon I'll get back to breaking La Clojure to keep you busy ;) Thanks again!

0

Please sign in to leave a comment.