Bug with La Clojure and Git

With the new La Clojure plugin for 107.127, when you try to clone a repository, you can't delete characters from the "Git Repository URL".

This shows up in the log:

2011-05-23 15:29:59,281 [ 171231]  ERROR - com.intellij.ide.IdeEventQueue - IntelliJ IDEA (Xena) IU-107.127  Build #IU-107.127
2011-05-23 15:29:59,281 [ 171231]  ERROR - com.intellij.ide.IdeEventQueue - JDK: 1.6.0_20
2011-05-23 15:29:59,281 [ 171231]  ERROR - com.intellij.ide.IdeEventQueue - VM: Java HotSpot(TM) Client VM
2011-05-23 15:29:59,281 [ 171231]  ERROR - com.intellij.ide.IdeEventQueue - Vendor: Sun Microsystems Inc.
2011-05-23 15:29:59,281 [ 171231]  ERROR - com.intellij.ide.IdeEventQueue - OS: Windows XP
2011-05-23 15:29:59,297 [ 171247]  ERROR - com.intellij.ide.IdeEventQueue - Error during dispatching of java.awt.FocusEvent[FOCUS_GAINED,permanent,opposite=com.intellij.ui.EditorComboBox[,104,1,341x22,invalid,layout=javax.swing.plaf.basic.BasicComboBoxUI$Handler,alignmentX=0.0,alignmentY=0.0,border=com.incors.plaf.alloy.cu@10e114f,flags=4194632,maximumSize=,minimumSize=,preferredSize=,isEditable=true,lightWeightPopupEnabled=true,maximumRowCount=8,selectedItemReminder=git+ssh://mydev.hq/home/build/gitMaster/MyProject.git],cause=UNKNOWN] on EditorComponent file=null
java.lang.NullPointerException
 at com.intellij.openapi.components.ServiceManager.getService(ServiceManager.java:40)
 at org.jetbrains.plugins.clojure.settings.ClojureProjectSettings.getInstance(ClojureProjectSettings.java:42)
 at org.jetbrains.plugins.clojure.editor.braceHighlighter.ClojureBraceHighlighter.updateBraces(ClojureBraceHighlighter.java:93)
 at org.jetbrains.plugins.clojure.editor.braceHighlighter.ClojureBraceHighlighter$3.focusGained(ClojureBraceHighlighter.java:72)
 at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
....

I've submitted a bug here.
http://youtrack.jetbrains.net/issue/CLJ-95
Is that the right place?

Thanks,
Adam

Please sign in to leave a comment.