Why are there bugs in recent updates?

I kept update each time. However, each update will bring a new bug.

Now the bug is disconnect with the database.

[2015-10-09 16:40:28] java.lang.ClassNotFoundException: org.jetbrains.jdba.jdbc.PostgresIntermediateFacade
 at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
 at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
 at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:331)
 at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
 at com.intellij.database.remote.jdbc.impl.RemoteDriverImpl.connect(RemoteDriverImpl.java:27)
 at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
 at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
 at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
 at java.lang.reflect.Method.invoke(Method.java:497)
 at sun.rmi.server.UnicastServerRef.dispatch(UnicastServerRef.java:323)
 at sun.rmi.transport.Transport$1.run(Transport.java:200)
 at sun.rmi.transport.Transport$1.run(Transport.java:197)
 at java.security.AccessController.doPrivileged(Native Method)
 at sun.rmi.transport.Transport.serviceCall(Transport.java:196)
 at sun.rmi.transport.tcp.TCPTransport.handleMessages(TCPTransport.java:568)
 at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run0(TCPTransport.java:826)
 at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.lambda$run$256(TCPTransport.java:683)
 at java.security.AccessController.doPrivileged(Native Method)
 at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run(TCPTransport.java:682)
 at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
 at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
 at java.lang.Thread.run(Thread.java:745)
[2015-10-09 16:42:22] java.lang.ClassNotFoundException: org.jetbrains.jdba.jdbc.PostgresIntermediateFacade
 at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
 at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
 at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:331)
 at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
 at com.intellij.database.remote.jdbc.impl.RemoteDriverImpl.connect(RemoteDriverImpl.java:27)
 at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
 at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
 at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
 at java.lang.reflect.Method.invoke(Method.java:497)
 at sun.rmi.server.UnicastServerRef.dispatch(UnicastServerRef.java:323)
 at sun.rmi.transport.Transport$1.run(Transport.java:200)
 at sun.rmi.transport.Transport$1.run(Transport.java:197)
 at java.security.AccessController.doPrivileged(Native Method)
 at sun.rmi.transport.Transport.serviceCall(Transport.java:196)
 at sun.rmi.transport.tcp.TCPTransport.handleMessages(TCPTransport.java:568)
 at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run0(TCPTransport.java:826)
 at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.lambda$run$256(TCPTransport.java:683)
 at java.security.AccessController.doPrivileged(Native Method)
 at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run(TCPTransport.java:682)
 at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
 at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
 at java.lang.Thread.run(Thread.java:745)

7 comments
Comment actions Permalink

Hello Runpeng Chen,

Does the error persist? Could be that installation is broken. Please download the build from https://confluence.jetbrains.com/display/DBE/0xDBE+1.0+EAP and re-install the application. Does it help?

0
Comment actions Permalink

Hi Andrey,

The problem still exists. Last update it works fine for me, although not perfect. But this time it totally doesn't work any more.

Best,
Runpeng

0
Comment actions Permalink

What OS are you running on? Does re-installing help?

0
Comment actions Permalink

Windows 7. I reinstalled it again, but the problem is same

0
Comment actions Permalink

What type of distribution do you use?


If you're using a zip archive, please make sure you're not extracting it's contents over a previous installation.

0
Comment actions Permalink

Did you download new distribution and installed it? After what action does it occur? Please try to re-download database driver for the datasource.

If problem remains, please attach idea.log https://intellij-support.jetbrains.com/hc/en-us/articles/206827517 after IDE restart and reproducing the problem. Please provide also output from Test Connection button for your Datasource. Thanks.

0
Comment actions Permalink

oh, that solved my problem! I have no idea why just simple replacement doesn't work. After I deleted all files, it works.

Thank you !

0

Please sign in to leave a comment.