Permanently blinking "Updating OSGi indices..." in statusbar in existing Grails project

Hello,

I've just started using IntelliJ IDEA on an existing Grails project (others have been developing with IDEA on it, project file was checked into git). The IDE is always busy doing something in the background (CPU load), which seems to be "Updating OSGi indices...". The UI behavior is therefore expectedly sluggish all the time. This has been going on for hours in the past days, so I expect every type of indexing to have fully completed at least once.

I'm not aware of us using OSGi. Can it be turned off? "Do not synchronize dependencies" in Settings -> OSGi didn't help. Disabling OSGi plugins in Settings -> plugins (those that turn up searching "osgi": dmServer support, Osmorc, Spring OSGi) seems to get rid of the blinking "Updating OSGi indices...", but CPU is still quite busy. In an open groovy file, in the right upper corner of the editor, the red square has a blinking eye, tooltip switching between "Performing code analysis..." and "Analysis completed".

IDEA 12.1.4
JDK 1.7.0_09
Grails 2.1.1
ArchLinux
Intel(R) Core(TM) i7-2620M CPU @ 2.70GHz

Why does IDEA think something is changing all the time? What else can I do to hunt this down?

Regards
David

10 comments

Please provide a CPU snapshot (http://devnet.jetbrains.com/docs/DOC-192)

A workaround could be to disable OSGi plugin (Settings | Plugins)

0

Uploaded to FTP:

ftp://ftp.intellij.net/.uploads/IU-129.713_david_16.09.2013_15.08.21.zip

A single groovy source file is open in the editor. I just started the CPU profiler, clicked around, typed in a comment and saved. Then I stopped the CPU profiler.

The eye with "performing code analysis" was and is still permanently blinking in the top right editor corner.

Thanks
David

0

Hello David,

could you disable "Gradle" plugin and check if the problem still exists?

0

Hi Vladislav,

thank you so far, I can confirm that disabling the Gradle plugin does indeed stop the permanent indexing. The heavy CPU load is gone, and the editor is responsive.

As soon as I enable it, the problem comes back.

Do you have an idea what the Gradle plugin is doing?

Thanks,
David

0

There was an excessive usage of listener for project modification in this version of the plugin.
If you need Gradle plugin for your project, try to update to the recent version of the plugin (Pre-assembled set (applicable for the IJ v.12.1.x))

0

Hi,
I've the same issue here. Gradle plugin turns IDE unusable.
I try to use the suggested build of plugin with no lucky.
I'm on Mac OSX 10.9 Mavericks, IDEA 12.1.6, Java 1.6.0_65.

Any help?

Thanks!

avaz

0

Hi,

I couldn't answer before.
I tried the IDEA 13 EAP and the Gradle plugin is working fine is this version.

Thanks,

Anderson Vaz

0

I have the same problem with the Intellij IDEA 13.0.2

0

Please sign in to leave a comment.