Update from 9 to 10: Grails module dependencies not resolved and not applicable

Going from IntelliJ IDEA UI 9.0.4 to UI 10.0.2 we have encountered a problem: in our Maven (2.0.9) based project with many Grails (1.1.1) plugins the inter-plugin dependencies are lost.

Applying inter-plugin (module in IntelliJ speech) dependencies via Project Settings-Module Selection-Dependencies-Add Module-Dependency-Ok fails. After revisiting the dialog the previously selected dependencies are gone.

IDE settings have not been imported from old IDE verstion to new. The project has been simply opened. Saving the project in a directory based format did not help to solve the problem.

This is a blocker for us, the code is full with "Cannot resolve symbol" errors.

I'd be thankful for any hint regarding if this is a know issue and how to fix.

3 comments
Comment actions Permalink

I can see that the iml-files are touched and the modules are added, but only for a bit, they are removed again.

This looks like a bug to me, maybe the iml file is getting saved twice, once with the new modules and once without?!

0
Comment actions Permalink

When adding the module dependencies manually to the iml file, the module dependencies get removed when starting the IDE.

0
Comment actions Permalink

Just to let others possibly benefit from the hint JetBrains' support sent me:

You can disable automatic management of project structure by passing
system variable 'grails.disable.structure.update=true' to IDEA jvm. (Add
line '-Dgrails.disable.structure.update=true' to file 'idea.vmoptions'
in '%IDEA_HOME%/bin').
0

Please sign in to leave a comment.