0xDBE EA MySQL version 5.5 -> 5.6 not recognized

I just updated one of the older MySQL dbs from 5.5 to 5.6 and seems like 0xDEB doesn't recognize the version change since it still tries to set options with old "OPTION SQL_SELECT_LIMIT=502" instead of "SET OPTION SQL_SELECT_LIMIT=502". I haven't found anyway to change version for datasource, am I missing something?

2 comments
Comment actions Permalink

Hello Tero,


Make sure that jdbc driver version you use is 5.1.18 or newer. You can see it when select Test Connection for MySQL Data Source properties. Please attach the output here.

it still tries to set options with old "OPTION SQL_SELECT_LIMIT=502" instead of "SET OPTION SQL_SELECT_LIMIT=502".


Do you see any errors highligting in database console or when querying the tables? Please attach screenshot, showing the problem. Thanks.

0
Comment actions Permalink

Thanks for answer and solution. Little bit miss leading that  "Data Sources and Drivers" lists java-connector 5.1.31 budled with 0xdbe, but "Test Connection" showed that much older version was in use. So I hunted that down and replaced it with the latest one and everything works now. Thanks again!

0

Please sign in to leave a comment.