IDEA 9.0 & Grails 1.2, no way to compile my project.

Hi,
I'm using idea 9.0 (build 93.13) with a pretty big grails project.
This project is in grails 1.2.0, and I simply can't compile it with idea.

First, I have a dependency on jasper report, defined in buildconfig.groovy, and it is not seen.

dependencies {
    //  specify dependencies here under either 'build', 'compile', 'runtime', 'test' or 'provided' scopes eg.


    build ('jasperreports:jasperreports:3.5.3', 'commons-collections:commons-collections:3.2.1')  {
      excludes "xml-apis"
    }
  
    runtime 'mysql:mysql-connector-java:5.1.9'
    
  }


and the compilation end in :


/home/ofe/dev/projets/App_trunk/MyApplication/src/java/com/fcad/conf/jasper/datasource/DeliverablesDataSource.java
    Error:Error:line (4)package net.sf.jasperreports.engine does not exist
    Error:Error:line (5)package net.sf.jasperreports.engine does not exist
    Error:Error:line (6)package net.sf.jasperreports.engine does not exist
    Error:Error:line (25)cannot find symbol class JRDataSource
    Error:Error:line (41)cannot find symbol class JRDataSource
    Error:Error:line (61)cannot find symbol class JRException
    Error:Error:line (70)cannot find symbol class JRField
    Error:Error:line (70)cannot find symbol class JRException


And I have more errors, probably not related :
For example, a test doesn't compile.

/.generated/groovyStubs/MyApplication49016a1e/MyApplication/tests/com/fcad/conf/application/deal/QuoteServiceTests.java
    Error:Error:line (3)package com.fcad.configurator.application.domain.catalog does not exist
    Error:Error:line (9)package com.fcad.configurator.application.domain.deal does not exist
    Error:Error:line (16)cannot find symbol class QuoteService
    Error:Error:line (17)cannot find symbol class QuoteService
    Error:Error:line (16)cannot find symbol class QuoteService



It works perfectly with the command line.

I've made a clenup of everything, dropped my ~/.Intellij folder, and so on.
I used to have -Duse.groovyc.stub.generator=false in my idea.vmoption file, I removed it.

But no way to compile this project...

Any clue ?

regards.

1 comment
Comment actions Permalink

answer to my self, the dependencies management is the root of the issue.
All the errors cascade from the missing jasper library.

0

Please sign in to leave a comment.