Confused on Grails Version

Where does Idea U-90.193 manage which version of grails I am using for my grails project?  I am just looking for a method to upgrade my project from 1.1.1 to 1.1.2 and there doesn't SEEM to be any straightforward method.  When I upgrade from command line, Idea tries to downgrade me to 1.1.1 again!

Overall I'd like to get a handle on how 9.0 has handles Grails.  I can't seem to find ANY place where I can manage my different Grails installations (1.1.1, 1.1.2, etc) within Idea.  I think this used to be kept in the IDE settings.  I'm confused as to why Grails is handled so differently from other frameworks.

Thanks for any help,

Bill

1 comment
Comment actions Permalink

The Grails version IDEA uses is the one in your module dependencies. So
you could remove that dependency and add another one. I agree it's not
straghtforward, we'll probably add an 'Upgrade' or 'Change Grails
version' action to IDEA. Could you file a YouTrack issue please?

0

Please sign in to leave a comment.