Firebird JDBC not working

Hi

Im trying to use OxDBE with Firebird JDBC driver, but it's not working.
My env:

Mac OS X 10.9.2
Java(TM) SE Runtime Environment (build 1.6.0_65-b14-462-11M4609)
0xDBE 138.551
jaybird-2.2.5

Screen Shot 2014-06-25 at 1.53.49 PM.png

Does anyone tried to use Firebird JDBC and had success with it?

Thanks

Paulo

1 comment
Comment actions Permalink

I got it to work.
First, you'll need to update / install JRE (the latest jdbc driver requires 1.8 jre). If you are using 32bit 0xDBE, you should place your new jre inside the 0xDBE root jre folder.
The x64 version will find the current installed JRE / JDK version from the registry.
I was getting the same error as you with a bad connection string, my working one is jdbc:firebirdsql:localhost:test?rewriteBatchedStatements=true
and in case you didn't - you should specify jdbc driver class name (org.firebirdsql.jdbc.FBDriver) and add the jdbc driver file (jaybird-full-2.2.5.jar in my case)
Now you should be able to establish your connecton.

As for my overall experience so far - its just bad:
     - You cant edit stored procedures (!) (I bet it is the firebird jdbc drivers issue, it has some syntactic troubles about stored procs)
     - Its just slow, way slower than IBExpert for example
     - Got out of memory on some easy queries

So yeah, give it a try

0

Please sign in to leave a comment.