SELECT INTO OUTFILE query truncating results

SELECT
  id,
  email
FROM users
WHERE email REGEXP '^[A-Z0-9._%-]+@[A-Z0-9.-]+\.[A-Z]{2,4}$'
      AND date(lastseen) > '2014-05-01'
ORDER BY id ASC
INTO OUTFILE '/tmp/users-2014-08-01.tsv'
FIELDS TERMINATED BY '\t'
LINES TERMINATED BY '\n';


I'm trying to run this query and it only outputs 500 rows into the output file. When I run the same query in SequelPro it outputs 183MB worth of data (so hundreds of thousands of rows). Any idea what might be the problem here?
1 comment
Comment actions Permalink

I'd guess that similar to the Save Data To File functionality (See http://youtrack.jetbrains.com/issue/DBE-442), 0xDBE doesn't directly pipe output to a file as requested.

In this case, your truncated results appear to be limited by the "Result set page size" setting. (Settings > IDE Settings > Database). Increase that number, and see if you get the same results.

0

Please sign in to leave a comment.