IdeaVim not working in latest build

Just installed the latest EAP which allows plugin install. I installed IdeaVim, restarted, but it is not working in the SQL editor. The Github page for the plugin says to enable it in the Tools menu but DBE does not have a tools menu. In IntelliJ the tools menus has a ctrl-alt-v shortcut next to IdeaVim in the Tools menu so I tried that in DBE. This changes the cursor to a square from a line, but does not enable IdeaVim.

5 comments
Comment actions Permalink

I believe I had a similar issue when I first installed IdeaVim. In Settings->Keymap, verify that "Escape" is not bound to an IDE command. Mind shows it as having no vavlue.

0
Comment actions Permalink

Hmmm... that doesn't seem to help me. I went into the keymap and the only entry is a line item named 'Escape' which appears to be mapped to 'Escape' (see screenshot). If I edit the line item I can choose 'Remove Escape', but this doesn't seem to make a difference.

Screenshot from 2014-08-06 07:47:19.png
Hmm... screenshot isn't coming through. Here is a link: https://www.dropbox.com/s/7o218ezvj2d0vt1/dbe_ideavim.png

0
Comment actions Permalink

I had the same issue. When you install the plugin you don't have to activate it.

You can exit insert mode with either Escape, Ctrl-C or Ctrl-[

If you want to redefine this key, edit "Exit Insert Mode" under Settings -> Keymap -> Plugins -> IdeaVim.

I did set it to Escape and it works now. Note that there was a conflict which I ignored.

0
Comment actions Permalink

Thanks!

This is the key: Edit "Exit Insert Mode" under Settings -> Keymap -> Plugins -> IdeaVim.

0
Comment actions Permalink

I have the same issue in Ver 2016.2.4. what I found is that the shortcut for Vim Emulator(Ctrl + Alt + V, under Keymap - Plug-ins - IdeaVim) is conflict with KeymapMain Menu - Refactor - Extract - Variable. So I remove Ctrl + Alt + V under Main Menu, everything is ok then.

3

Please sign in to leave a comment.