Updated to 138.1400.3 and Windows Auth for SQL Server still doesn't work...

I just updated to 138.1400.3 to test the SQL Server Windows Auth functionality since it didn't work in the previous release. It doesn't seem to be working for me in this latest version. I keep getting error 08s01 "The TCP/IP connection to the host has failed." I have tried entering in the host as both SERVERNAME and SERVERNAME\INSTANCENAME. I can connect to the server using SQL Server Mgmt Studio without issue. We are not running any firewalls on our computer that could also potentially block the application from communicating with the server. In the Driver Files section, it lists I'm using the SQL Server/Microsoft driver files. It prompted earlier to install a driver update and it appeared to install successfully. I tried using jTds but it did not have a checkbox for Windows Auth so I continued to use the MS driver.

This is the full error message:
Connection to SQL Server - @SERVER\INSTANCE failed
java.sql.SQLException: The TCP/IP connection to the host SERVER, port 1433 has failed. Error: "connect timed out. Verify the connection properties. Make sure that an instance of SQL Server is running on the host and accepting TCP/IP connections at the port. Make sure that TCP connections to the port are not blocked by a firewall.".

3 comments
Comment actions Permalink

Confirming the same problem. I also tested the format test@domain

0
Comment actions Permalink

Hello.

The feature works in our environment - so it looks like some specific condition is essential.

Googling the exception message brings quite a lot of results from different sources. Sorry if I suggest something evident: this is rather blind search.

One possible solution is described here: http://www.coderanch.com/t/306316/JDBC/databases/SQLServerException-TCP-IP-connection-host
Quotation: "SQL Server Configuration Manager -> Protocols  for SQL SQLEXPRESS, select Properties of TCP/IP. In the tab IP  Addresses, set the TCPPort in section IPAll to 1433."
Can it be the case?

Thank you,
Alexander.

0
Comment actions Permalink

I could have sworn our SQL Server was running on port 1433. I decided to run "netstat -a -b" and looked for Ssms.exe. I discovered it was communicating via port 5552. I updated the port and it connected successfully. I still find this odd as I never configred a port when using SQL Server Mgmt Studio and for a PHP web application we have that access that SQL Server. So far it seems to work.

0

Please sign in to leave a comment.