sbt issue when changing scalacOptions in ThisBuild ++= Seq("-target:jvm-1.6")

I think this is a bug.

I changed the target jvm to jvm-1.6 and then jvm-1.8 and then jvm-1.7 and back to 1.6 but the ide gives me an error:

Error:scalac: bad option: '-target:jvm-1.8'

This is jvm-1.6 in my build.sbt and I've re-imported the sbt project.

I've noticed this in .idea/scala_compiler.xml :

<?xml version="1.0" encoding="UTF-8"?>
<project version="4">
  <component name="ScalaCompilerConfiguration">
    <option name="uncheckedWarnings" value="true" />
    <option name="featureWarnings" value="true" />
    <parameters>
      <parameter value="-target:jvm-1.6" />
      <parameter value="-target:jvm-1.8" />
      <parameter value="-target:jvm-1.7" />
    </parameters>
  </component>
</project>

If I remove the invalid parameters and refresh the project, the issue is resolved.

Is this a bug?

Please sign in to leave a comment.