How does JetGroovy recognize a proper Grails SDK (related to Grails 1.1)

Using IDEA 7.0.5 with the latest JetGroovy plugin, I can't get the grails module withing my project to recognize grails-1.1-beta1 as a proper Grails SDK.  When I try, it just reverts the dropdown back to no SDK.  Grails 1.0.4 works fine though.  If I had more insight into how JetGroovy validates that this is a Grails distribution then hopefully I could trick it, short of fixing JetGroovy to recognize 1.1 projects.

Thanks,
Mike

Grails user list thread for reference: http://grails.markmail.org/search/?q=jetgroovy#query:jetgroovy+page:1+mid:64pimkaspmusqiuq+state:results

5 comments

Hello, Mike.

It seems that something has changed in project structure of Grails 1.1 application. If it's so than this is a bug. I'll check it.
Thanks.

With best regards,
Ilya

0

Hi Ilya,

Thanks.  I confirmed, though not a surprise, that this is a problem in 8.* as well.

Thanks,
Mike

0

Hi Ilya,

I tried tinkering with the grails 1.1 beta1 distribution to see if I could identify some workaround for this problem, hoping it was something simple.  I found that Intellij successfully read the grails version out of the core jar in the /dist directory but choked while loading the jars in dist.  If I replaced the jars in dist with those from 1.0.4 and hacked a file in /conf directory I could get it to load as a 1.0.4 sdk.  My first thought was that it might have something to do with the way 1.1 handles plugins but this seems to indicate it's something with the new way the jars in /dist are packaged.

Anyway, this is a show-stopper for me.  I'm mid stream in a project that plans to go-live with Grails 1.1 in February and we're using the 1.1 beta 1 distribution currently.  Unfortunately I've started looking at alternatives to Intellij with respect to Grails rather than upgrading from v7 to v8 and buying another license for another team member.  I REALLY like Intellij; any idea when this might be addressed?

Thanks,
Mike

0

FYI, I was having all the problems with grails 1.1 beta, but finally got things working. I'll describe the fix for the problem where the "Run Grails" from inside the IDEA fails, I'm not sure if this is a grails issue or jetgroovy, but for whatever reason the ${grails.version} in groovy-starter.conf isn't working. So you need to explicitly define the file name in GRAILS_HOME/conf/groovy-starter.conf. And of course have the correct jetgroovy plugin. So the line below works for me using IDEA EAP 9572 + jetgroovy 21538 + grails 1.1-beta2.

    load ${grails.home}/dist/grails-bootstrap-1.1-beta2.jar

0

Please sign in to leave a comment.