Anyone get latest plugin to work with Scala 2.11.4?

I changed my scala version in my SBT file to 2.11.4. Everything compiles OK but the syntax highlighting shows a lot of red for silly things like Some/None, tailrec, etc.
2.11.2 works fine.


Syntax highlighting works fine for me with Scala 2.11.4 and plugin 1.0.246.
If I run into issue with syntax highlighting I do "File > Invalidate Caches > Restart", sometimes also need to do "Refresh all SBT projects" from "SBT" tab.


I use Intellij Idea on two Ubuntu (14.04-1) systems, and the experience is different on them:

1) 64-bit Ubuntu 14.04: Scala-2.11.4 works perfectly well, as does 2.11.2.
2) 32-bit Ubuntu 14.04: Scala-2.11.4 fails as described in the original post.

But even in case (2) above, the Scala-2.11.4 installation itself probably is fine, and it looks like an IDE issue.


Thanks for the invalidate cache idea. I got it working now on 1.0.246.


With Idea14, I suddenly have problems in my Scala code, lots of red, e.g.:  ListBuffer, listBuffer.toSeq, scala.collection.mutable.ListBuffer, List(), string.toInt, Some(elem), ...

I tried Invalidate Cache & Restart, but it didn't fix the problem.


Yah, me too. However, the invalidate caches did work for me.


Please sign in to leave a comment.