Exception Analyzer questions

I'm confused about exceptions showing up in the current 14 EAP build 138.1696 that have a status of fixed in prior builds after I submit. See the first two below for examples. How can the exception continue to show up after it has been addressed? Is this not something new?

Also, what does it mean when status is build #Dev?

Thanks,
Jon

ID Build Status
705980 138.1696 build #132.303
705940 138.1696 build #138.1403
705930 138.1696 build #Dev
4 comments
Comment actions Permalink

The first and second problem looks like platform problems. If build is newer that "Fixed in build ..." then I think problem will be reopened automatically (this is some kind of problem in Scala plugin, when with older plugin same exception can come in newer build of IntelliJ IDEA, then it will be reopened and I have to close it again).
The third problem was probably matched by mistake to other platform problem, which was fixed earlier too. SOE below looks like quite important problem, but it would be great to reproduce it somehow to see actual type, which causes this SOE. If it's possible, you can create new issue in our issue tracker.

Dev build means build, which was built from sources.

Best regards,
Alexander Podkhalyuzin.

0
Comment actions Permalink

Done:
http://youtrack.jetbrains.com/issue/SCL-7509

When an exception occurs and is captured by the Exception Analyzer during Optimize imports, could Exception Analyzer issue note which particular file that Optimize imports was processing? I run these in batches and am not sure which file caused the problem. If it noted the file, I could possibly take a snapshot for you.

Jon

0
Comment actions Permalink

Could you maybe add more statuses, like "Open", "Cannot reproduce"? For example http://youtrack.jetbrains.com/issue/IDEA-129062 - the bug was in several EAPs and every exception I reported had "Fixed in build Dev" and it was not fixed, not even in master.

0
Comment actions Permalink

I'm not responsible for Exception Analyzer functionality, and I'm pretty sure, that getting the same issue in newer builds is reopening issue. However I'll forward your message to responsible guy to check, what's possible to do in this direction.

Best regards,
Alexander Podkhalyzuin.

0

Please sign in to leave a comment.