5 comments
Comment actions Permalink

Erik,

Please, look at your value of blank lines number after class header in IDEA code style settings ('Blank Lines' tab, section 'Blank lines'). If I understand right your issue, it seems that in your case this value equals zero. That's why in your example first line of code can be put on next line after class header or not. But as I see, example in http://www.jetbrains.net/jira/browse/GRVY-1451 is incorrect because of lost statement separator.

0
Comment actions Permalink

But if we reproducer java-like behavior, you're right, it would be better ot insert new line in that case by default.
Thanks. we'll change it.

0
Comment actions Permalink

Hi Ilya,

I don't quite understand what the statement separator is, but if you can fix it, it would be great. The JIRA issue formatted wrong btw, Jira is stripping some of the CRLF's...

The code I have looks like this:


will be reformatted to :


I have indeed the header setting to 0, but I have that in Java too, and I don't want to change tha, because I don't want an empty line under the class header: I just don't want it appended to the end of the line. Do you need to reopen the issue, or do I have to add a new one with the same info (doesn't sound logical to me)?

0
Comment actions Permalink

There is no need for this, I've already fixed it. Thanks.

0
Comment actions Permalink

Great work, thanks!

0

Please sign in to leave a comment.