Disallow block imports when auto-importing

Lets say I have the following imports in my scala project...

import com.foo.bar
import com.foo.baz

If I have my cursor on an unknown `biz` which is also in the package `com.foo`, using the alt-enter auto import will get me:

import com.foo{bar, baz, biz}


Is there a way to forgo this functionalty and keep every import on its own line?  I figured out how to stop the underscore import from appearing automatically(by default after 4 or 5 common package imports), but this is still a nitpick for me... any help is appreciated.


Cheers,
Stephen

1 comment

I reworked adding/optimizing imports functionality recently. So it's available as new setting in Code Style -> Scala -> Imports. It's available in the latest nighlty builds, or it will be released next week in regular plugin update.

Best regards,
Alexander Podkhalyuzin.

0

Please sign in to leave a comment.