Scala plugin not working

I have installed the Scala plugin from the plugin manager and restarted IntelliJ. I created a new Scala project with SBT enabled. From the project src folder, when I right click, in the "New" context menu, I don't find "Scala Class" or anything scala related. For that matter, I don't see even Java there. All I see is "File", "Directory", HTML and XSLT. What am I missing here? I am using the latest IntelliJ, 13.1.2


This is the first step mentioned at http://confluence.jetbrains.com/display/IntelliJIDEA/Scala. I cannot continue with Step-2 since I don't find a "specify Scala home directory". Please let me know how to proceed.

4 comments

Right click on src folder and press "Mark as..." -> Source folder.

Best regards,
Alexander Podkhalyuzin.

0

Alexander,


Thank you. That makes it better. Right click, New, gives me more options such as Java Class, GUI Form etc., but I still do not see anything related to Scala. What am I missing here?

0

Actually in most cases you do not need to mark folder as source. In your case Scala Facet wasn't created either. So it's SBT integration problem. As workaround try to use old third-party gen-idea: https://github.com/mpeltonen/sbt-idea

However it would be good to understand what's wrong with our SBT integration, because it's much more convenient to generate IDEA project from SBT without command line.

Best regards,
Alexander Podkhalyuzin.

0

Yes, the SBT integration did not happen properly in my case. I also would like to go this way and make it convenient for myself. I would also like to import projects from the SBT file. I will list out the steps I followed, then, may be it would clear on where/what I missed.


I am using Mac OS X 10.6.8


1) Download IntelliJ Idea 13.1.2
2) From Preferences - > Plugins, select Scala plugin and install it. Restarted IntelliJ
3) From New Project..., select Scala and SBT based, give the name of the project and click Finish. JDK is already set to jdk 1.6

Thats all I did. If I missed something please let me know the steps to follow.

0

Please sign in to leave a comment.