sbt sporadically download sources

I'm using Idea 13.0.1 + Scala plugin 0.26.335 with sbt 0.13.1. For many of the dependencies, especially transitive ones, "Jump to Souce" (F4) jumps to the compiled class instead of the source. Source is definitely available in maven repo but did not get downloaded into ivy cache. Note that some direct dependencies like scala libs, akka, seem to download sources just fineTried the following:

  • sbt updateClassifiers - still no result.
  • make dependency direct + add withSource() to sbt dependency - source got downloaded to ivy cache but not seen by Idea.
  • click "Refresh" in sbt task panel, still not see source.
  • Add source manually in "Project Structure" makes Idea see the source and made it debuggable.
  • click "Refresh" in sbt task panel - source jar is gone.


All in all, I'd expect the source loading from maven repo to be automatic/on-demand. This is an attempt to move from maven to sbt and we still need to improve this aspect a lot to be really viable.

Thanks!

Please sign in to leave a comment.