Spurious Groovy (Grails) Result From "Find Usages"

Hi,

I got what appears to be a spurious result from an invocation of "Find Usages".

Specifically, I ran Find Usages on a Java class named OpConf that had no extends clause and an "implements Cloneable" clause.

This invocation of Find Usages had all the "Find" check-boxes enabled and neither of the "Options" check-boxes enabled. I ran the search over the entire project, which has two modules, one of which includes a Grails application.

In addition to the results I expected (all of which were within OpConf itself, since I was confirming that I'd yet to put this class into use), the find results included, under "Dynamically typed usages," one invocation of "clone()" on a completely unrelated Grails domain class instance.

Randall Schulz

1 comment

You probably included "usages of methods"; one of them happened to be clone() from Cloneable. And naturally these include dynamic usages as well.

Eugene.

0

Please sign in to leave a comment.