JetGroovy fails with Error: Exception in thread "main"

I'm running Intellij 7.0.1 on Windows and downloaded JetGroovy. When I create following script:

println "Hello from groovy"

it fails when I run script within intellij with:

Error: Exception in thread "main"

When i go and run script from command line, it works fine. I've installed the jetgroovy aspect, when I go to create new file it gives me option to create groovy script.

I suspect I've missed something simple in the config. Any advice appreciated.

Message was edited by:
Tony Obermeit

6 comments

I've tried using ctrl-shift F9 to compile, followed by ctrl-shift F10 to run and am better able to capture the failure....

No message
java.lang.NullPointerException
at java.io.File.]]>(File.java:262)
at org.jetbrains.plugins.groovy.runner.GroovyScriptRunConfiguration.getAbsoluteWorkDir(Unknown Source)
at org.jetbrains.plugins.groovy.runner.GroovyScriptRunConfiguration$1.createJavaParameters(Unknown Source)
at com.intellij.execution.configurations.JavaCommandLineState.getJavaParameters(JavaCommandLineState.java:30)
at com.intellij.execution.runners.RunStrategyImpl.executeCommandLine(RunStrategyImpl.java:54)
at com.intellij.execution.runners.RunStrategyImpl.a(RunStrategyImpl.java:72)
at com.intellij.execution.runners.RunStrategyImpl.access$200(RunStrategyImpl.java:10)
at com.intellij.execution.runners.RunStrategyImpl$3.run(RunStrategyImpl.java:11)
at com.intellij.execution.impl.ExecutionManagerImpl$1.run(ExecutionManagerImpl.java:15)
at com.intellij.openapi.application.impl.LaterInvocator$FlushQueue.run(LaterInvocator.java:20)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:597)
at com.intellij.ide.IdeEventQueue.c(IdeEventQueue.java:111)
at com.intellij.ide.IdeEventQueue.b(IdeEventQueue.java:53)
at com.intellij.ide.IdeEventQueue.dispatchEvent(IdeEventQueue.java:92)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:273)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:183)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:173)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:168)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:160)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:121)

0

Do you set working directory for your run configuration on a different drive than that where the project is stored?

0

My project file is on c:\documents and settings\tobermei\IdeaProjects\scripts

My groovy installation dir is: d:\bin\groovy10\groovy-1.0

My Project source is: d:\idea\scripts\src

I'm new to using this plugin, does the "it is fixed" mean you found the problem and I can download new plugin? or does it mean you've found the problem and you will advise an eta of when i can download the new plugin?

Thanks so much for the quick response!

0

Well, I commited a fix, and in case you need it now, you can build it from sources yourself. We are going to update it in plugin manager some time later this week.

Eugene.

0

Excellent. Thanks. I'm really impressed with the speed this has been resolved. I will post a response once I've got the fix installed to confirm that it solved my issue.

Message was edited by:
Tony Obermeit

0

Please sign in to leave a comment.