Scala debugger settings don't stick/work

Under preferences->Debugger->Scala, I un-check "Friendly display of Scala collections in Debugger". Click "Apply" then "OK".  When I open the settings page again, the option is checked again. Same is true of all options in this dialog. Something very strange though, if you look at the behaviour of the "Apply" button, it does NOT agree with the state of the check marks.

It is impossible to turn off the "Friendly Scala collections" feature. This is inconvenient for me since I have many classes which implement Traversable which are being interpreted as scala collections. In order to expand them I first have to right-click and choose "view-as/toString".

Finally, under the view-as menu, I often see "Friendly Scala Collections" appear in the menu, 2, 3 or even 4 times.

1 comment
Comment actions Permalink

I created the issue, so you can watch it: http://youtrack.jetbrains.com/issue/SCL-6301

Best regards,
Alexander Podkhalyuzin.

0

Please sign in to leave a comment.