slashy string with slash

I think there is a bug in the highlighting of slashy strings that have a slash in them. For example, this assertion "passes" but the JetGroovy plugin highlights the line as red and indicates "Expression expected".

assert "image/pjpeg" == /image\/pjpeg/

4 comments

We fixed that problem. You should update JetGroovy to the last version in plugin manager.

Eugene.

0

Could you explain the procedure to update the plugin? (I am not an experienced IntelliJ user.) I thought I had the latest version but now I'm not sure. I tried last week to download the plugin and install manually, but this failed. Next I tried the suggestions from another thread in this forum (titled "New build is available in plugin manager") that said: delete plugin, then download and install again. I just did this procedure and still see the slashy slash problem. (BTW, the Plugin manager says the latest available JetGroovy plugin has a date of August 10, 2007) Any help will be appreciated. Thanks.

0

I can only hope the folks in Russia have gone home to their families by now, so I'll answer.

It's as simple as can be, you just activate the IDEA settings dialog (the simplest way being to click the wrench icon in the toolbar, otherwise File -> Settings) then if it's not open, expand the "IDE Settings" section. Near the bottom is the Plugins icon. Click it and the Plug-ins panel will display and IDEA will immediately retrieve from the plug-in repository server the list of available plug-ins. The Plugins panel has two tabs, one show the currently installed plug-ins and the other showing all the available ones. If an installed plug-in has a new version a distinctive icon is shown in the "Installed" tab. Just right click and tell it to update.

Much simpler than manual installation, though that's not too hard, either.


Randall Schulz

0

Thanks, but that technique wasn't working for me in the build I had -- the Plugin-ins panel was only showing and downloading a version of JetGroovy from August. I'm up and running now that I downloaded IDEA #7343 and manually downloaded JetGroovy. And best of all, the slash issue has indeed been fixed.

0

Please sign in to leave a comment.