Can I not use sbt 0.13 with Intellij?

I get the following when trying to import an sbt using sbt plugin 0.1.55:


java.lang.reflect.UndeclaredThrowableException

Caused by: com.intellij.openapi.externalSystem.model.ExternalSystemException: [ERROR] Terminal initialization failed; falling back to unsupported
Error during sbt execution: java.lang.IncompatibleClassChangeError: JLine incompatibility detected.  Check that the sbt launcher is version 0.13.x or later.
java.lang.IncompatibleClassChangeError: Found class jline.Terminal, but interface was expected
 at jline.TerminalFactory.create(TerminalFactory.java:101)
 at jline.TerminalFactory.get(TerminalFactory.java:159)
 at sbt.ConsoleLogger$.ansiSupported(ConsoleLogger.scala:85)
 at sbt.ConsoleLogger$.<init>(ConsoleLogger.scala:79)
 at sbt.ConsoleLogger$.<clinit>(ConsoleLogger.scala)
 at sbt.GlobalLogging$.initial(GlobalLogging.scala:40)
 at sbt.StandardMain$.initialGlobalLogging(Main.scala:54)
 at sbt.StandardMain$.initialState(Main.scala:60)
 at sbt.xMain.run(Main.scala:26)
 at xsbt.boot.Launch$.run(Launch.scala:55)
 at xsbt.boot.Launch$$anonfun$explicit$1.apply(Launch.scala:45)
 at xsbt.boot.Launch$.launch(Launch.scala:69)
 at xsbt.boot.Launch$.apply(Launch.scala:16)
 at xsbt.boot.Boot$.runImpl(Boot.scala:31)
 at xsbt.boot.Boot$.main(Boot.scala:20)
 at xsbt.boot.Boot.main(Boot.scala)

java.lang.IncompatibleClassChangeError: JLine incompatibility detected.  Check that the sbt launcher is version 0.13.x or later.
 at sbt.ConsoleLogger$.ansiSupported(ConsoleLogger.scala:96)
 at sbt.ConsoleLogger$.<init>(ConsoleLogger.scala:79)
 at sbt.ConsoleLogger$.<clinit>(ConsoleLogger.scala)
 at sbt.GlobalLogging$.initial(GlobalLogging.scala:40)
 at sbt.StandardMain$.initialGlobalLogging(Main.scala:54)
 at sbt.StandardMain$.initialState(Main.scala:60)
 at sbt.xMain.run(Main.scala:26)
 at xsbt.boot.Launch$.run(Launch.scala:55)
 at xsbt.boot.Launch$$anonfun$explicit$1.apply(Launch.scala:45)
 at xsbt.boot.Launch$.launch(Launch.scala:69)
 at xsbt.boot.Launch$.apply(Launch.scala:16)
 at xsbt.boot.Boot$.runImpl(Boot.scala:31)
 at xsbt.boot.Boot$.main(Boot.scala:20)
 at xsbt.boot.Boot.main(Boot.scala)

 at org.jetbrains.sbt.project.SbtProjectResolver.resolveProjectInfo(SbtProjectResolver.scala:32)
 at org.jetbrains.sbt.project.SbtProjectResolver.resolveProjectInfo(SbtProjectResolver.scala:18)
 at com.intellij.openapi.externalSystem.service.remote.RemoteExternalSystemProjectResolverImpl$1.produce(RemoteExternalSystemProjectResolverImpl.java:41)
 at com.intellij.openapi.externalSystem.service.remote.RemoteExternalSystemProjectResolverImpl$1.produce(RemoteExternalSystemProjectResolverImpl.java:37)
 at com.intellij.openapi.externalSystem.service.remote.AbstractRemoteExternalSystemService.execute(AbstractRemoteExternalSystemService.java:59)
 at com.intellij.openapi.externalSystem.service.remote.RemoteExternalSystemProjectResolverImpl.resolveProjectInfo(RemoteExternalSystemProjectResolverImpl.java:37)
 ... 20 more


I find that "0SBT 0.13.* launchers not yet supported" in Idea. Does this mean I can't use 0.13 and Idea? I mean, the error I get is that 0.13 doesn't support being launched from 0.12 launcher, right? And Idea doesn't support 0.13 launchers? Any workaround?

Thanks,
Viktor

2 comments

I tried pointing out an 0.13 launcher just in case, but that gave me:

[error] java.lang.NoSuchMethodError: sbt.Extracted.structure()Lsbt/Load$BuildStructure;

0

Hi Viktor! SBT 0.13 launchers are not supported yet, we're going to add the support soon. You may monitor SCL-6070 for progress on this.

0

Please sign in to leave a comment.