SBT plugin crashing when importing project

Stack trace is below. Could this be another of those Java 6 vs Java 7 things? I'm using sbt 0.13.0, so that shouldn't be a problem.

[ERROR] Terminal initialization failed; falling back to unsupported
Error during sbt execution: java.lang.IncompatibleClassChangeError: JLine incompatibility detected.  Check that the sbt launcher is version 0.13.x or later.
java.lang.IncompatibleClassChangeError: Found class jline.Terminal, but interface was expected
 at jline.TerminalFactory.create(TerminalFactory.java:101)
 at jline.TerminalFactory.get(TerminalFactory.java:159)
 at sbt.ConsoleLogger$.ansiSupported(ConsoleLogger.scala:85)
 at sbt.ConsoleLogger$.<init>(ConsoleLogger.scala:79)
 at sbt.ConsoleLogger$.<clinit>(ConsoleLogger.scala)
 at sbt.GlobalLogging$.initial(GlobalLogging.scala:40)
 at sbt.StandardMain$.initialGlobalLogging(Main.scala:54)
 at sbt.StandardMain$.initialState(Main.scala:60)
 at sbt.xMain.run(Main.scala:26)
 at xsbt.boot.Launch$.run(Launch.scala:55)
 at xsbt.boot.Launch$$anonfun$explicit$1.apply(Launch.scala:45)
 at xsbt.boot.Launch$.launch(Launch.scala:69)
 at xsbt.boot.Launch$.apply(Launch.scala:16)
 at xsbt.boot.Boot$.runImpl(Boot.scala:31)
 at xsbt.boot.Boot$.main(Boot.scala:20)
 at xsbt.boot.Boot.main(Boot.scala)

java.lang.IncompatibleClassChangeError: JLine incompatibility detected.  Check that the sbt launcher is version 0.13.x or later.
 at sbt.ConsoleLogger$.ansiSupported(ConsoleLogger.scala:96)
 at sbt.ConsoleLogger$.<init>(ConsoleLogger.scala:79)
 at sbt.ConsoleLogger$.<clinit>(ConsoleLogger.scala)
 at sbt.GlobalLogging$.initial(GlobalLogging.scala:40)
 at sbt.StandardMain$.initialGlobalLogging(Main.scala:54)
 at sbt.StandardMain$.initialState(Main.scala:60)
 at sbt.xMain.run(Main.scala:26)
 at xsbt.boot.Launch$.run(Launch.scala:55)
 at xsbt.boot.Launch$$anonfun$explicit$1.apply(Launch.scala:45)
 at xsbt.boot.Launch$.launch(Launch.scala:69)
 at xsbt.boot.Launch$.apply(Launch.scala:16)
 at xsbt.boot.Boot$.runImpl(Boot.scala:31)
 at xsbt.boot.Boot$.main(Boot.scala:20)
 at xsbt.boot.Boot.main(Boot.scala)


Consult IDE log for more details (Help | Show Log)

1 comment

The project is probably requires SBT 0.13, while the intellij-sbt plugin currently bundles 0.12 launcher.

We're going to add SBT 0.13 support soon (you may SCL-6070 for progress updates).

0

Please sign in to leave a comment.