Constant hard lockups in FileBasedIndexImpl

My IDEA (12.1.4) with Scala (0.19.298) is consistently freezing while editing Scala code. New imports, organizing imports, deleting a line, adding new code...IDEA hard freezes and I have to kill it. Stack traces show that different things are going on (Import code, syntax highlighting, etc) but I always have at least one thread, usually more, locked on semaphores from com.intellij.util.indexing.FileBasedIndexImpl.ensureUpToDate(FileBasedIndexImpl.java:830). The AWT EventQueue is usually one, which of course means that IDEA is completely unresponsive and has to be force-quit.

I'm not sure why this happened, but it seemed to appear after I was working with 2 projects in two windows / closing or opening one / switching between them.

I opened a ticket, but I was hoping somebody would have suggestions. I've lost hours dealing with this, and I tried using Eclipse...but...it was still Eclipse.

I've tried invalidating my caches, deleting my ~/Application Support/Caches/IntelliJIdea12 directory, creating a new project, rebooting...nothing works.

I'm attaching a thread dump from a few minutes ago showing 4 threads all locked up in the same spot.



Attachment(s):
threadDump-20130906-083636.txt.zip
1 comment

Hi, Steven,

Please try latest nighlty build: http://confluence.jetbrains.com/display/SCA/Scala+Plugin+Nightly+Builds+for+Leda
I probably fixed your problem, probably not. I don't know how to reproduce this problems, so I can't check it myself.

Best regards,
Aleksandr Podkhaliuzin.

0

Please sign in to leave a comment.