Error starting external compiler


10:04:52 Using a new (SBT-based) Scala compiler.
         In case of any compilation problems you may enable the previous (internal) compiler by clearing:
         Project Settings / Compiler / Use external build
10:04:52 Cannot launch Scala compile server
         JVM SDK does not exists: 1.7
         Please either disable Scala compile server or configure a valid JVM SDK for it.
10:04:52 Compilation aborted

Any ideas ??? Recently tried to change jdk but cannot see any setting to correct this issue.

Comment actions Permalink

IDE Settings -> Scala -> JVM SDK. Probably problem is here.

Best regards,
Alexander Podkhalyuzin.

Comment actions Permalink

Odd, complteley missed that - sorry :)

Comment actions Permalink

I cannot find this setting. I'm using 129.298 and Scala Plugin 0.7.220.

I also couldn't find it using the search. Neither in module nor project settings.

# Edit

Right after hitting enter here, I found it. But searching in the combined Project/IDE settings didn't reveal it. This is a bug or are only project settings searchable?


Please sign in to leave a comment.