Scala plugin compatibility

Hi, I'm using Idea 12 123.100, and the scala plugin refuses to load (and the play 2 plugin too, because of dependencies).

So my question is if there is a version of the plugin that is compatible with 123.100?

It also seems that 123.100 is an EAP for Idea 12.0.2

I don't know why I'm using that. It just offered me to upgrade from 12.0.1 (123.94) to this one so I thought it was a release version, not an EAP. Is it another option to downgrade to 12.0.1? How can I downgrade without losing all the plugins I've already downloaded and the configuration I already have?

Thanks,
Luciano.

4 comments
Comment actions Permalink

i use the newest nightlies together with the newest eaps. works fine

0
Comment actions Permalink

Ok the nightly build worked fine. I hope that when a new version is released, it gets updated automatically.

0
Comment actions Permalink

you can set up idea to automatically update the plugin when a new nighly build is available. that's what i do, they work fine in most cases.

instructions here:
http://confluence.jetbrains.net/display/SCA/Scala+Plugin+Nightly+Builds+for+Leda

0
Comment actions Permalink

Sorry, for the long answer.
http://plugins.intellij.net/plugin/?idea&pluginId=1347 contains build 0.7.58, which is compatible with any IDEA version, but plugin manager can't update 0.7.62 to version 0.7.58. So workaround is to remove Scala plugin and then to add it again.
But of course it's our mistake with such situation, I'll upload newer plugin version today, and we will try to avoid such problems in the future.

Best regards,
Alexander Podkhalyuzin.

0

Please sign in to leave a comment.