Project does not compile with Idea

Project does not compile with Idea - on different rebuilds, differrent compilation errors can show. Maven builds ok.Tried 12 Preview and 11 with latest plugins. Tried rebuild, maven reimport, invalidate caches, switching betwen fsc and ordinary compiler, building on different hard disk.

2 comments
Comment actions Permalink

Me too. Here are some errors I'm getting. It used to compile OK. Most of the errors have to do with arguments with default values in scalafx. All files in the editor show green.


error: not enough arguments for constructor BorderPane: (delegate: javafx.scene.layout.BorderPane)scalafx.scene.layout.BorderPane
val bp = new scalafx.scene.layout.BorderPane {



error: value toRelativeString is not a member of org.joda.time.DateTime
assert(date2.toRelativeString(testDate) === "Dec 31 23:59")


The last error is because it doesn't seem to find an implicit class.

UPDATE: had to recompile scalafx with 2.10-RC2 and all compiles successfully now.

0
Comment actions Permalink

Try to disable "External compiler" (it's not supported yet, it will be supported in integration with SBT in the nearest future). Settings -> Compiler -> External compiler.

Best regards,
Alexander Podkhalyuzin.

0

Please sign in to leave a comment.