IDE is not working anymore for Scala 2.9.0.RC3

Ok, here is what I've done:
1. Uninstalled Scala 2.9.0.RC1 (everything worked ok till now)
2. Installed fresh Scala 2.9.0.RC3 in the same location as the previous version.
3. Recompiled project with SBT - success.
4. Started IntelliJ.
5. Issued "Invalidate caches and restart"
6. Issued "Rebuild project"
7. The compiler got to the final phase, when it displays "wrote .... class" on the status line...
8. and then suddenly gave me 1136 errors of a kind:
"SomeClass to C:\Users\Piotr\Projekty\ .... \out\production\projectname\pl\pk\...\SomeClass.class (File name, directory name or volume label syntax is incorrect)."

I rechecked my setup and can't find what can be wrong.
I also tried to delete the whole out directory and rebuild - no effect - still the same error and the class files are not being put into the output directory.

What could go wrong?

System: Windows Vista Home Premium.
No system updates were applied - the RC1 -> RC3 was the only change I performed.
Scala plugin version: 0.4.968

8 comments
Comment actions Permalink

Additional update: moved back to RC1 and the scala plugin works back again.
I can't check RC2 because my project hangs on RC2 due to a compiler bug.

Anyone here has tried RC3 with IntellliJ already?

0
Comment actions Permalink

It's possible that compiler API was changed from RC1 to RC3, we will check it.

Best regards,
Alexander Podkhlalyuzin.

0
Comment actions Permalink

The plugin is now compatible with RC3. Thank you for the report!

0
Comment actions Permalink

I have the same problem, but IDEA will work with a simle project,

If you try to build this project (https://github.com/max-l/Squeryl) with IDEA :

at this branch and commit :

  https://github.com/max-l/Squeryl/commit/19f99753ccdebcaa716967d854d606bfd2352b71

The project builds correctly with SBT, with IDEA
you will see a strane error : it complains of not being able to find any of the 900+ .class files,
and gives a path that is correct, if you check on the file system, the files *are* there.

Like I said, I tried compiling a simpler project and it did work.

I have the same problem with Scala2.9.RC4

Thanks

0
Comment actions Permalink

The same problem happens with Scala 2.9.0 final release

0
Comment actions Permalink

See: http://youtrack.jetbrains.net/issue/SCL-3185

The compiler output changed, we had to update our compiler driver.

You will need to use IDEA 10.5 with an updated version of the Scala plugin to compile with Scala 2.9.0. This is a free upgrade from IDEA X. I think the release will happen pretty soon, or you can use a release candidate with a nightly build of the Scala plugin.

0

Please sign in to leave a comment.