New stable release unbearably slow

Hi,

Just upgraded to latest stable plugin (0.4.735) on 10.0.2, but it is unbearably slow.

Simply typing text (repeatedly) into a comment pegs the cpu at 100% and the editor cannot keep up with my typing (and I'm not that fast :-). Pressing enter in a scala file takes up to 1s to be executed.

I've tried disabling scala aware type highlighting, setting highlighting to none, but this didn't seem to make a difference.

Any hints?

Update: Setting highlighting to none and restarting seems to solve the problem.

/Jeppe

6 comments
Comment actions Permalink

I noticed this too. I upgraded to 0.4.748 and it was better. Not great,
but better.

The only drawback is that you have to switch to the 10.5 EAP.

Donald

On 3/30/11 2:51 PM, Jeppe Nejsum Madsen wrote:

Hi,

>

Just upgraded to latest stable plugin (0.4.735) on 10.0.2, but it is unbearably slow.

>

Simply typing text (repeatedly) into a comment pegs the cpu at 100% and the editor cannot keep up with my typing (and I'm not that fast :-). Pressing enter in a scala file takes up to 1s to be executed.

>

I've tried disabling scala aware type highlighting, setting highlighting to none, but this didn't seem to make a difference.

>

Any hints?

>

Update: Setting highlighting to none and restarting seems to solve the problem.


0
Comment actions Permalink

Can you capture a CPU Snapshot for 20-30 seconds and submit a bug? (Search -> Find Action -> Capture CPU Usage Snapshot).

Thanks,

Jason

0
Comment actions Permalink

I could if I could find that entry? Nothings shows with the name Capture  (On OS X, IntelliJ 10.0.2)

Do I need to do something special to enable the Capture CPU functionality (I'm a relative new IntelliJ user :^O)

/Jeppe

0
Comment actions Permalink

In my installation (I'm using the 10.5 EAP, which I recommend for Scala
since all new versions of the plug-in will be built for it) the Capture
CPU Usage Data can be found on the row of icons just below the title
bar. It looks like an old floppy disk with a clock superimposed on it.

Donald

On 3/30/11 7:35 PM, Jeppe Nejsum Madsen wrote:

I could if I could find that entry? Nothings shows with the name Capture  (On OS X, IntelliJ 10.0.2)

>

Do I need to do something special to enable the Capture CPU functionality (I'm a relative new IntelliJ user :^O)

0
Comment actions Permalink

Capture CPU snapshot requires the YourKit agent to be added to the JVM options of IntelliJ.

This is enabled by default in Early Access Preview (EAP) builds of IntelliJ. Alternatively, you can add this line to idea.exe.vmoptions (assuming you're on Windows) Not sure offhand about the Mac/Linux way to do this.

-agentlib:yjpagent=disablej2ee,disablecounts,disablealloc,sessionname=IntelliJIdea10

-jason

0
Comment actions Permalink

I've updated to 10.5 EAP but yourkit seems not to be bundled on OSX. I've installed the yourkit trial and made snapshot and attached it to http://youtrack.jetbrains.net/issue/SCL-2994?projectKey=SCL.

Let me know if you need more details.

/Jeppe

0

Please sign in to leave a comment.