Editing Scala code has become painfully slow since I upgraded to IDEA 10.0.1

Hi, editing Scala code  has become painfully slow since I upgraded to IDEA 10.0.1,
Am I alone experiencing this ?

Would love to selectively disable features to get the speed back,

otherwise this version has nice improvements over the last one,
but the slowness is painfull....

Will send any detail, run whatever diagnostics if it can help.

Thanks

5 comments
Comment actions Permalink

Is it freezing during typing? Or just slow highlighting and completion? I slightly improved perfomance in past few days, you will be able to try it in next nightly build.
Which Scala plugin version are you using?

Best regadrs,
Alexander Podkhalyuzin.

0
Comment actions Permalink

The Scala plugin version is 0.4.407

It's slow when typin, even moving the caret is slow.

It would be nice if ther was a settings panel where we could selectively disable/enable features, like code completion, syntax highliting, etc,
I figure it might also help identify problems like these.

Cheers !

0
Comment actions Permalink

What you can do is to disable language injection (please use speed search through settings). There was such issue about language injection for scala files (in newer builds It's fixed, so you can download latest IDEA EAP build with latest Scala plugin, or to wait IDEA 10.0.2).
Also in the latest nightly build I improved parser perfomance, and general perfomance. So typing in very big files (like Typers.scala in scala-lang, it's about 4500 lines) was slightly improved, but if for your typing was ok (in previous scala plugin builds), so that wasn't your problem.

Best regards,
Alexander Podkhlayuzin.

0
Comment actions Permalink

Hi Alex, disabling injection like you suggested solved the problem,
for you information, the slowness was occuring even on files with aprox 300 lines.

Thanks for the help, for this great plugin and IDE;-)

0
Comment actions Permalink

Next nightly build (>525) should significantly improve the performance of language injection in Scala, so you may consider turning InlelliLang on again.

(btw, you may equally well disable "IDE Settings / Editor / Code Completion / Autopopup code completion" instead of IntelliLang)

0

Please sign in to leave a comment.