11 comments

Yes, latest release in plugin manager is for 98.117.

Best regards,
Alexander Podkhalyuzin.

0

Hmm. Unable to install it. It shows up in the Plugin manager and seems to download correctly + ask for reinstall, but no Scala facets are available. Any log file I could look in for more info? I'm on MacOS.

0

On 10/12/10 12:47 AM, Dag Liodden wrote:

Hmm. Unable to install it. It shows up in the Plugin manager and seems to download correctly + ask for reinstall, but no Scala facets are available. Any log file I could look in for more info? I'm on MacOS.


That's weird. I am on MacOS 10.5.8 and had no problems with the plugin
(version 0.4.176)

0

Please, ensure that the plugin is enabled (in Settings / Plugins / Installed list).

Additionally, check Getting Started with IntelliJ IDEA Scala Plugin and the tips on how to configure a Scala project.

0

Thanks, the problem was actually that it wasn't enabled (as you pointed out). Somewhat strange that it happened now as I've been updating regularly the last few months. Anyway, it works perfectly now.

Thanks for you help!

0

Idea X 98.117 and Scala plugin 0.4.176 (downloaded via Plugins Manager) doesn't work for me (OSX 10.6.4, Java 1.6.0_20).

I can create a new module with Scala facet
Screen shot 2010-10-12 at 23.25.50.png
but when trying to add new Scala class, it doesn't do anything and then tell me that the file already exists (see screenshot).create file.png
It turns out that it has indeed created that file but doesn't recognized as Scala file (no syntax highlighting, can't compile,see screenshot)
Screen shot 2010-10-12 at 23.23.52.png

Am I missing something here ?

0

Please check File Types in settings dialog.
There must be section about Scala and it must contain ".scala" extension.
Also please check that Plain Text section doesn't contain ".scala" extension.
Problem can be caused from moment when you installed wrong Scala plugin version (incompatible to IDEA version) and try to open scala file. Then IDEA (it don't know about Scala files without Scala plugin) suggest to open it like Text file. Then settings about ".scala" extenstion will be saved in File Types -> Plain Text section.
I hope it will help.

Best regards,
Alexander Podkhalyuzin.

0

That worked ! Many thanks.
Don't know why I had .scala associated with Text Files before.

0

If you start a version of idea that is not compatible with the scala plugin, the scala plugin gets disabled.

Then when you upgrade the scala plugin to a compatible one, it is still disabled.

This has caught me out as well. Maybe when you update a plugin that is currently disabled (as it is not compatible) it should enable it.

Thanks, Nick.

0

Yeah, that's probably what happened. Auto-enabling plugins that are updated "manually" sounds like a good idea. Or, at least, add an extra Enable when being asked to restart Idea after a successful download.

0

I've already created an issue: IDEA-59772, you may vote for it to raise its priority and speed-up the implementation process.

0

Please sign in to leave a comment.