Scala 2.8.0.RC3 library JAR does not load, works when unpacked

When I expand 'scala-library-2.8.0.RC3.jar', it is empty, and the expansion arrow disappears. When I switch focus away from IntelliJ, the arrow re-appears. Classes from the Scala library are not resolved and marked red.
rc3-jar.png


I selected the JAR, copied the path with ctrl-shift-c,  then unpacked to a temp folder

/tmp/scala-lib: jar xvf  /Users/jason/.m2/repository/org/scala-lang/scala-library/2.8.0.RC3/scala-library-2.8.0.RC3.jar

I added this to the library definition, and the contents are browsable, and the classes are resolved properly in the editor.

The JAR from came from: http://www.scala-tools.org/repo-releases/org/scala-lang/scala-compiler/2.8.0.RC3/scala-compiler-2.8.0.RC3.jar

I think this is the same problem reported by Adrian Powell on scala-user.

Any ideas what could be causing this?

-jason

3 comments
Comment actions Permalink

I'm using Windows 7 and IntelliJ 9.0.1.  I got the Windows 2.8.0 RC3 zip and extracted to c:\tools\scala then created a Global Library called "scala-2.8.0RC3" and added these jars (I've added the jars individually and added the entire lib directory, same effect).  In my project, I can see the scala library and all of the jars.  When I expand the JAR I can see the packages but there are no classes found in the package:

scala280.png


I can still build and run my programs which implies that the JARs are valid and are being picked up properly, they just are NOT recognized by the editor.  (maybe this means I have a different problem from Jason?)

Following the same process for scala 2.8.8 Beta1 and for past releases has worked successfully.

0
Comment actions Permalink

After upgrading to a clean 9.0.2 version and installing the Scala plugin, my projects all work.  I don't know if this means my 9.0.1 version had become corrupt or if there was a fix added but everything is working for me now.

0

Please sign in to leave a comment.