editor locks up during parsing

anyone else experiencing this? build 1196 doesn't have this problem, but the last few builds are unusable for me

27 comments

I've been out for a few days, so I can only speak to 1224. While it hasn't locked up, its is having some very long hangs. I don't see any patterns yet.

0

Can you send me lock's threaddump?

Best regards,
Alexander Podkhalyuzin.

0

Can you send me threaddumps for hangs? I'm working on type system now, it's possible that I broke performance.

Best regards,
Alexander Podkhalyuzin.

0

that's what i meant, it locks up for a few seconds. in my case, it happens after i make random changes to the source file. it doesn't seem to happen every time, but very often.
i'll make a cpu snapshot

0

how to switch on the "make cpu snapshot"-button?

0

On Windows, you can add the following line to idea.exe.vmoptions:
-------
-agentlib:yjpagent=disablej2ee,disablecounts,disablealloc,sessionname=IntelliJIdea90
-------

By the way, for a locked/unresponsive JVM process you can obtain a stack dump using the "jstack" tool from the JDK.

0

cpu snapshot attached. all i did was declaring an inner method in a 170 lines scala file



Attachment(s):
IU-95.66_HoD_29.04.2010_20.30.24.zip
0

another snapshop. the problem was severe in this case, the file almost uneditable



Attachment(s):
IU-95.66_HoD_30.04.2010_21.51.32.zip
0

Please try build 0.3.1289, whilch will be available in Nightly Builds page in 20 minutes. I improved performance, and I hope that it helps to you.

Best regards,
Alexander Podkhalyuzin.

0

I've been using 1289 most of today. Much better. Going to 1290 now.

0

1290 is fine & juicy
you fixed it.

0

While 1290 no longer locks up, it is quite sluggish.

0

for me, it's pretty good. you should upload a cpu snapshot, it's probably something that depends on the class(es) you are in and didn't happen for me. or maybe my machine is just too fast (corei7@3.6ghz, 12gb ram)

0

1315 is way way worse for me. I'll try to capture some dumps. So far I've been editing pretty simple unit tests, but they with SpecsMatchers and Specs has been triggered performance issues in the past.

0

here you go, the worst moments i could reproduce captured in a cpu snapshot. i had several more-than-a-second-lockups on my rather powerful machine.

if i can get even longer stops, i'll snapshot them, too

the third one was the most extreme, almost can't type in that file.



Attachment(s):
IU-95.105_HoD_12.05.2010_16.43.08.zip
IU-95.105_HoD_12.05.2010_17.05.35.zip
IU-95.105_HoD_12.05.2010_20.30.17.zip
0

I have the same problem. I get nearly constant lock-ups of up to 10 seconds. It only happens when editing, I can browse code fine.

I'm using Ubuntu 10.04 with java 1.6.0_19 (64bit) on Idea 9.0.2. I've tried with different scala plugin versions up to 1342. I've attached some jstack dumps taken when idea was hanging and a cpu snapshot too.

Hope this helps.



Attachment(s):
stack4.zip
stack3.zip
stack2.zip
stack.zip
IU-95.66_dave_13.05.2010_17.05.52.zip
0

I was shown a fix by our resident Idea guru. If you disable the toolbar (go to View -> Toolbar and deselect) everything runs fine.

0

but then the toolbar is gone which makes it rather difficult to press the buttons on it

0

I have the same issue with random lockups trying to type in a Scala source file using every plugin version since 1156.

I'm also using  Ubuntu 10.04 with java 1.6.0_20 (64bit) on Idea 95-105.  8GB memory.

There is a delay of about a second before each group of letters I type show up.  Any key press, including the arrow keys, causes memory usage to spike, and the after GC the cursor moves up.

In all these plugin versions, heapspace has boom and bust GC behaviour even when I am not focused on the editor - this is sharply different to the behaviour editing Java files which is usually slow steady growth followed by incremental GCs that do not interrupt editing.

I really appreciate all the work the Scala plugin developers have done to try to improve performance, but I believe something is still wrong on Ubuntu.

Disabling the toolbar had no effect.

(On a related note,  compiling is so mystifyingly slow I gave up trying to use Idea to make the projects  or run tests, and started using sbt in the console.)

0

removing the toolbar had no effect for me, but closing the structure view had. try it.

0

You don't have to close the Project window entirely, just set the "View as:" mode to "Project".

Randall Schulz

0

structure view, not project view. closing the project view had no effect

0

Thanks for your replies.

What seems to be happening is that the Scala plugin really does not like some of my code files, but is fine with others.  Even opening those files causes the editor to lock up for 10+ seconds over and over again.  Closing the structure view has no effect in those cases.  Idea will then exhibit boom-and-bust GC until I manage to close the offending file and restart.

Files that seem to be problematic: 6 traits in a single file, some Scalatest spec files (for reasons I haven't been able been able to link to number or length of scenarios).

Fortunately, yesterday and today so far have been OK with build 1389 as long as I don't touch those files...

0

post cpu snapshots and you'll get it fixed
or if possible, post a file that causes the problem

0

Thanks, HamsterofDeath.  In the lockup of the moment I accidentally took a memory snapshot intead of a CPU snapshot.

But some of the dreadful slowness seems to be caused by a StackOverflowError I noticed running Idea from console (Scala plugin build 1468).

I was trying to click through on a method in a Lift library when this StackOverflowError happened.  It locked up Idea for a good thirty seconds.  I didn't get a CPU snapshot but I have a 200+ MB memory snapshot.

Attached is a tgz of my Idea.log file.  Alexander, if you're reading this, should I file a ticket as well?



Attachment(s):
prasinous_idea_log.tar.gz
0

This SOE was fixed in 1473.
Also I found a way to speed up editor twice, and using memory same amount less. Just need to resolve few synchronization issues. So I hope next nightly will be faster without locks.

Best regards,
Alexamder Podkhalyuzin.

0

Thanks, Alexander, I've been using built 1473 all day and it's been working great.  Much appreciated!

0

Please sign in to leave a comment.