Problems running Tests

I'm having trouble running my Specs test cases. It works when I'm using the class-version of the run configuration. This works for both Specs configuration and ScalaTest when mixing the ScalaTestRunner into the test class.

But when I'm switching to package mode in the run configuration I get the error "Not found suite class" for both ScalaTest and Specs.

What do I have to enter in the class field? A package name and all classes in that package get run?

How do the regexps exactly work?

A help page would be useful.

I'm using Scala 2.8.0 Beta and the according test libraries. The scala plugin is 863 and Idea is 500-something (the current one at the time of writing).

3 comments

Have you found a solution for this? I'm having the same issue after installing the most recent EAP version of intellij and the most recent scala plugin. (things worked in the plugin for the 9.0.1 release).

I hate to say this, but using this ide for scala is becoming a pain, every new update seems to break existing functionality. And moreover,. every new update takes me hours to configure to make it actually compile my project due to subtle changes. Having non descript compiler error messages (that could be made more explicit with a secret?! (http://git.jetbrains.org/?p=idea/scala-plugin.git;a=commit;h=563ff3ffb6e49ae63c937fc95d447515fcb12209) option didn't help either) I'm all for "hide unnecessary option/details details from the user" but well.. having an error message that actually means something would be sweet.

Having experienced this before, you might wonder why i even bothered upgrading to the new build, well, using the scala compiler deamon seemed promising Big mistake as in the end i didn't even get it to work.

0

If you are using scala compiler from plugin directory, then after upgrading you can find new compiler bugs, or just your dependencies is different from using compiler version.
I'll look at bug with running tests on package to fix it. Thank you for your report.

Best regards,
Alexander Podkhalyuzin.

0

Tests run again with the nightly of 10th of april. Thanks a lot!! I'll not try other versions/updates of this plugin or ide anymore unless i absolutely need to

(It's still a bit strange, as the specs runner claims some test were skipped (but, it was like this before, it's not a new issue), and indeed it only shows about half my specs. Nevertheless the others are run, and when they produce errors they are shown, so I don't really care about this little weirdness)

Edit: Got the scala compilation server to work too. This is a HUGE increase is useabilty/userfriendliness (when my project was small compilation times didn't matter much, but it's turning into a behemot) keep the great work going!

0

Please sign in to leave a comment.