Return of the Horrendous CPU-Saturated Pauses

Hi,

Since I upgraded my project to Scala 2.8, I find that those horrible pauses that interrupt everything have returned. And some of them happen even when no modification has been made to the file being edited (e.g, when opening the "Find in Path..." dialog or when a rename refactoring is initiated (even one for a local variable).

I'm not sure why switching to 2.8 would cause this, but it's extremely frustrating and I hope it can be addressed soon.

IDEA: 9.0.1 #IU-93.94
Java: Sun JDK 1.6.0_u17
OS: Linux 2.6.27
arch: x86 (32 bits)


Randall Schulz

7 comments
Comment actions Permalink

It would be great to see thread dump.
Also I can suggest you to try to upgrade to IDEA 94.xxx. Maybe it helps.

Best regards,
Alexander Podkhalyuzin.

0
Comment actions Permalink

I am having exactly the same problem, and currently I am really desparate.

Before blaming the Scala plug-in, I checked every other possibility, disabled other plug-ins that might be responsible, reduced the IDEA settings to a minimum. I even optimized my system, like turning off background file indexing and the like. I checked both the current official IDEA release version, and the latest EAP. Disabling the Scala plug-in was only an act of desparation, because I would not really have expected it to be responsible for the pauses. But unfortunately, I quickly found out it was!

Here is a list of things that I tried which all did not help:

- shut down Chrome browser
- disabled IDEA memory status
- shut down iTunes
- disabled smooth scrolling
- disabled method separators
- using latest eap release
- using -server option in .vmoptions
- setting right JDK path in idea.bat
- changing java.exe to javaw.exe in idea.bat
- putting "start" before the line that launches java.exe
- disabled editor drag'n'drop
- disabled subversion



None of it helped. I get terrible pauses that make the IDE practically unusable. After disabling the Scala plug-in, boom, no more delays, everything works super fast now.

I did most of the tests mentioned above on a Windows machine. But I am also using a Mac, which shows the same effect, although much less severe. On the Mac, I can tolerate the few-second pauses every now and then.

One thing that might interest you is that I also have the pauses when editing plain text files in IDEA (*.txt). I find that strange because I would have thought that the Scala plug-in has nothing to do with those.

I am not sure, but it might be that the pauses only occurred after I switched to Scala 2.8. I did not test this though, because my code cannot compile under 2.7 any more.

Those pauses are really bad for me right now. If there is anything I can do to help you fix it, please tell me what it is.
0
Comment actions Permalink

After finding this thread, I read that disabling the toolbar might solve the problem. I tried, and at first sight, it seems that the pauses are gone. I hope they won't return.

Strange. I would never have suspected the toolbar.

0
Comment actions Permalink

Hi,

I'm not sure whether it's better to ask this here or in that older thread, but I decided here.

I cannot seem to find how to disable the toolbar. What's the trick?


By the way, for me these pauses are only sporadic and not at all frequent. Since I wrote the original post in this thread, the problem has not reoccurred.


Randall Schulz

0
Comment actions Permalink

Hi Randall,

if I had known the other thread before, I'd probably have posted there.

Anyway - disabling the toolbar is pretty easy: Use the menu. "View > Toolbar"
It's a bit contraintuitive though - in most Windows applications, you can disable the toolbar by right clicking it. That's probably why you did not find the option.

0
Comment actions Permalink

Windows? What's "Windows?"

Anyway, I'd looked in the Settings dialog, not the menus.


Randall Schulz

0
Comment actions Permalink

Sorry - I was simply assuming that you used Windows. Not that improbable, after all.

0

Please sign in to leave a comment.