plugin 0.2.25499 (maia10558) throws Compiler internal errors

Dear JetBrains Team,

I am getting Compiler internal errors after upgrading from 0.2.25444 (9m1) to 0.2.25499(maia10558). (the same classes compiled with  0.2.25444)

I tried  to empty my cache etc. etc.


I logged the issue here:
http://www.jetbrains.net/jira/browse/SCL-1222

Please let me know if you need more information.

Thanks
Peter

4 comments
Comment actions Permalink

Is it possible that you lost dependency on JUnit4 during update in Idea project?

Best regards,
Alexander Podkhalyuzin.

0
Comment actions Permalink

Hi Alex,

it's a maven based project and junit is included as a depedency, so it's certainly there. (Also, i can compile and run the tests from the command line or from intellij with maven). Also, I tried with empty cache so caching could not be an issue.  I switched back to the previous version which is working as expected (on the same classes)

Thanks,
Peter

0
Comment actions Permalink

Ditto here. Same problem. Can compile fine on the command line but no project no matter how minimal throws this error. It seems to always occur after the compilation but during the cache write at the end.

0
Comment actions Permalink

Hi, Aria.

One possible cause of the problem you've mentioned is not found scala library in a project with several modules. As a possible workaround try to attach library with Scala library classes to all of modules in your project.

With best regards,
Ilya

0

Please sign in to leave a comment.