Should 2.8 be expected to work?

I'm getting compiler exceptions when I compile. I haven't looked into this much yet, but here's the stack trace I'm getting:


Information:Compilation completed with 16 errors and 0 warnings
Information:16 errors
Information:0 warnings
Error:Scalac internal error: class java.lang.reflect.InvocationTargetException [sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method), sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39), sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25), java.lang.reflect.Method.invoke(Method.java:597), org.jetbrains.plugins.scala.compiler.rt.ScalacRunner.main(ScalacRunner.java:74)][scala.tools.nsc.Main.main(Main.scala), sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method), sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39), sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25), java.lang.reflect.Method.invoke(Method.java:597), org.jetbrains.plugins.scala.compiler.rt.ScalacRunner.main(ScalacRunner.java:74)]
Error:sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
Error:sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
Error:sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
Error:java.lang.reflect.Method.invoke(Method.java:597)
Error:org.jetbrains.plugins.scala.compiler.rt.ScalacRunner.main(ScalacRunner.java:74)
Error:Caused by java.lang.NoClassDefFoundError: scala/util/PropertiesTrait
Error:scala.tools.nsc.Main.main(Main.scala)
Error:Caused by java.lang.ClassNotFoundException: scala.util.PropertiesTrait
Error:java.net.URLClassLoader$1.run(URLClassLoader.java:200)
Error:java.security.AccessController.doPrivileged(Native Method)
Error:java.net.URLClassLoader.findClass(URLClassLoader.java:188)
Error:java.lang.ClassLoader.loadClass(ClassLoader.java:307)
Error:sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
Error:java.lang.ClassLoader.loadClass(ClassLoader.java:252)
Error:java.lang.ClassLoader.loadClassInternal(ClassLoader.java:320)

2 comments
Comment actions Permalink

It's a compiler internal bug.
Try to compile it without IDEA and you'll get same thing.
So I can suggest you to use more stable compiler version or hack your code to avoid this problems.

Best regards,
Alexander Podkhalyuzin.

0
Comment actions Permalink

Ah, I didn't get around to trying from the command line. Thanks. I guess I'll stay with 2.7.4 ;-)

0

Please sign in to leave a comment.