JSLint ES6 (Pycharm 2016.1)

My root issue is that I would like to use JSLint with ES6, specifically, I'm having issues with it reporting errors using the template string syntax (``)

I don't see an option to enable ES6 support (which, IMO, should be enabled dynamically according to Libraries in Scope), so I added the hint

/* jslint es6 */

to the top of the file. JSLint halts on this with the error "unexpected es6". Which leads me to believe PyCharm is using an older version of JSLint.

1) Is there a better way to enable ES6 support for JSLint?

2) Is there a way to upgrade JSLint to enable ES6 support?

Please sign in to leave a comment.