Scala plugin 0.2.18465 working with IDEA 8769?

After a few weeks of not trying IDEA 8 and the Scala plugin, today I installed build 8769 and then the Scala plugin 0.2.18465. It appears that the two are not compatible (see exception below). Removing the plugin's directory (config/plugins/Scala/) allows me to startup again.

I realize you're working hard on IDEA 8 and are working with limited resources on the Scala plugin--still, if there is an incompatibility it would be helpful if you could post this in the release notes (e.g. "this build of IDEA breaks the current version of the Scala plugin").

Thanks!
Patrick


^[[5;3~2008-09-07 16:41:20,365 INFO - #com.intellij.idea.Main - -


IDEA STARTED -



2008-09-07 16:41:20,516 INFO - j.ide.license.impl.IdeaLicense - Network startup failed.
2008-09-07 16:41:22,967 ERROR - com.intellij.ide.IdeEventQueue - Error during dispatching of java.awt.event.InvocationEvent[INVOCATION_DEFAULT,runnable=com.intellij.idea.MainImpl$3@175870a,notifier=null,catchExceptions=false,when=1220798482597] on sun.awt.X11.XToolkit@f4aa7a
java.lang.AbstractMethodError
at com.intellij.openapi.fileTypes.impl.FileTypeManagerImpl.]]>(FileTypeManagerImpl.java:302)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Class.java:247)
at com.intellij.openapi.components.impl.ComponentManagerImpl$ComponentsRegistry.a(ComponentManagerImpl.java:26)
at com.intellij.openapi.components.impl.ComponentManagerImpl$ComponentsRegistry.a(ComponentManagerImpl.java:30)
at com.intellij.openapi.components.impl.ComponentManagerImpl$ComponentsRegistry.access$100(ComponentManagerImpl.java:50)
at com.intellij.openapi.components.impl.ComponentManagerImpl.a(ComponentManagerImpl.java:11)
at com.intellij.openapi.components.impl.ComponentManagerImpl.initComponents(ComponentManagerImpl.java:124)
at com.intellij.openapi.components.impl.stores.ApplicationStoreImpl.load(ApplicationStoreImpl.java:3)
at com.intellij.openapi.application.impl.ApplicationImpl.load(ApplicationImpl.java:243)
at com.intellij.idea.IdeaApplication.run(IdeaApplication.java:47)
at com.intellij.idea.MainImpl$3.run(MainImpl.java:3)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:597)
at com.intellij.ide.IdeEventQueue.c(IdeEventQueue.java:207)
at com.intellij.ide.IdeEventQueue.b(IdeEventQueue.java:216)
at com.intellij.ide.IdeEventQueue.dispatchEvent(IdeEventQueue.java:10)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:273)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:183)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:173)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:168)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:160)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:121)
2008-09-07 16:41:22,968 ERROR - llij.ide.plugins.PluginManager -
java.lang.Error: ComponentSetup for component com.intellij.openapi.components.impl.ServiceManagerImpl already registered
at com.intellij.openapi.components.impl.ComponentManagerImpl$ComponentsRegistry.a(ComponentManagerImpl.java:68)
at com.intellij.openapi.components.impl.ComponentManagerImpl$ComponentsRegistry.a(ComponentManagerImpl.java:30)
at com.intellij.openapi.components.impl.ComponentManagerImpl$ComponentsRegistry.b(ComponentManagerImpl.java:47)
at com.intellij.openapi.components.impl.ComponentManagerImpl$ComponentsRegistry.access$300(ComponentManagerImpl.java:40)
at com.intellij.openapi.components.impl.ComponentManagerImpl.hasComponent(ComponentManagerImpl.java:101)
at com.intellij.idea.IdeaLogger$1.getInfo(IdeaLogger.java:5)
at com.intellij.idea.IdeaLogger.a(IdeaLogger.java:70)
at com.intellij.idea.IdeaLogger.error(IdeaLogger.java:59)
at com.intellij.openapi.diagnostic.Logger.error(Logger.java:56)
at com.intellij.ide.IdeEventQueue.c(IdeEventQueue.java:20)
at com.intellij.ide.IdeEventQueue.b(IdeEventQueue.java:216)
at com.intellij.ide.IdeEventQueue.dispatchEvent(IdeEventQueue.java:10)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:273)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:183)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:173)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:168)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:160)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:121)

5 comments
Comment actions Permalink

Yes, it's our fault, and this version with non-defined upper version bound should be removed as it's done now. We will upload actual one soon.

Ilya

0
Comment actions Permalink

Yes, it's our fault, and this version with non-defined upper version bound should be removed as it's done now. We will upload actual one soon.

Ilya


Thanks for the reply/confirmation, Ilya. I'll look forward to the next plugin update.


Patrick

0
Comment actions Permalink

Also anxiously awaiting the next version.

-Eric

0
Comment actions Permalink

Patrick

New version of Scala plugin for last Diana EAP is uploaded to plugin repository.

Ilya

0
Comment actions Permalink

Hi Ilya


Patrick

New version of Scala plugin for last Diana EAP is uploaded to plugin repository.

Ilya


Am now able to launch IDEA 8 with the plugin installed. Thanks for the note.

Patrick

0

Please sign in to leave a comment.