Changes to unshelving in 2016.1

 I can't find mention of this in the What's New, but I'm sure something odd has changed in unshelving in 2016.1.

When I go to unshelve changes, sometimes only one copy of my change (in my project's /src dir) is unshelved. The one in /public doesn't get unshelved. Is the part of the dialog where you can select specific files to unshelve new? In any case, I make sure all files are ticked, but sometimes not all are unshelved.

Also, I'm sure the checkbox to 'remove successfully applied files from shelf' is new. Again, there seems to be inconsistent behaviour with this. But one thing is that if I check it, sometimes a copy of my shelf seems to appear with 0 files.

I can't work out the logic to all this. It used to be that unshelving 'just worked'. Now all sorts of confusing things seem to happen. Maybe I'm using the new features wrongly but I can't find accurate documentation explaining what's changed.

2 comments

Hello,

Could you provide step-by-step guide on how to reproduce this, please? Like what to shelve and then unshelve to see this behavior?

0

OK, this seems to be related to my Grunt / Git setup in some way. Assume a /src dir and a /public dir. Steps to replicate:

  1. Make a change to a file in /src
  2. Grunt watch copies the change to /public
  3. Shelve the changes
  4. Unshelve

What I'm left with is that the changes seem to be unshelved, but even though I checked 'Remove successfully applied files', the shelf is still there - AND there's a copy of the shelf with zero files in it. (Or this is the original shelf, somehow persisting without files, and a new copy has been created with the changes).

I usually do this when I'm working on one branch and I suddenly need to shift the changes to another branch. I shelve, checkout the other branch, unshelve. I thought it might be related to some combination of this and the Grunt watch / copying, but the issue still happens even if I don't switch branches.

Also, I've tried making the changes, allowing Grunt to copy, terminating the Grunt watch process, then doing the shelving - still happens. Like this:

  1. Make a change to a file in /src
  2. Grunt watch copies the change to /public
  3. Stop Grunt watch process
  4. Shelve the changes
  5. Unshelve

Again I'm left with unshelved changes and 2 shelves, one with files, one without.

0

Please sign in to leave a comment.