View in Browser only works if files in /Application/AMPPS/www (not default Phpstorm-Projects folder)

The only way I can get View in Browser to work is copy the file into the localhost folder (.../www) from the PhpStorm default folder in my home directory. 

Any help for a student php noob would be appreciated

4 comments
Official comment

An example of a simple scenario:

1. Make sure you have "In place" set as default server (mappings tab or a server+green check button)

2. Port 63342 is taken from Settings > Build, Execution, Deployment > Debugger: Built-in server > Port

 

Let us know how it goes.

Dmitry I appreciate the response. When I added the implace server got a 404 Not Found error. When I set the default server to ampps it runs the program and displays in Chrome.Don't want to take your time with this as it maybe frustrating with my inexperience. Is there a chat available from a support desk? I can't find one on the JetBrains page. Would really like to give PHPStorm a go. I have TeamViewer app for remote access. Thanks again for responding and your help,


Regards Kim

0

Hi there,

1) When working with PhpStorm's own built-in simple web server .. then URL has to be like http://localhost:63342/PROJECT_NAME/

2) If you do not have any Deployment entries specified, then the built-in web server will be used automatically for you.

3) If you want to use your Apache as web server .. then you need to specify Deployment entry and configure it (first 2 tabs -- "Connection" and "Mappings")

More on deployment:

1

Kim, unfortunately we don't have something like live chat, but you can submit a support ticket at https://intellij-support.jetbrains.com/hc/en-us/requests/new?ticket_form_id=66731

 

It's totally fine to bother us with setting things up for the first time :)

1

Please sign in to leave a comment.