JSON Schema doesn't understand "array" type?

Answered

I tried to use the JSON Schema support last night, and it keeps telling me "Type is not allowed" whenever I have an 'array' type.  I've tried an example from the json schema site, and I've run it through a web-based validator to make sure it wasn't something I was doing wrong.

Screencaps:  http://imgur.com/a/o4Kga

Validator:  http://jsonschemalint.com/draft4/

Sample Data: http://json-schema.org/example1.html

I removed the warehouse information from the last sample on the page because I saw the bug report for non-relative references not working.  The rest *should* work, though, but doesn't.

3 comments
Official comment

I've tested given example in latest PhpStorm EAP and those are looking good:

What version are you at? Could you please try to download and test it using EAP build?

 

Edit: wrong screenshot. Replaced.

I was at the latest stable release, 2016.1.  I updated my home machine to the latest EAP and it seems to be working there.  Thank you.

0

Please sign in to leave a comment.