How to set encoding in Message Output?

Answered

I'm using Win10 x64 with Chinese Language. Some cli outputs are in Chinese, they don't display correctly in IntelliJ IDEA (in this screenshot, I'm using Clion compile, but this also happens when I run automated tasks from IDEA).

I've already tried setting -Dconsole.encoding=UTF-8 and it doesn't help. The Terminal (Alt+F12 on windows) works fine and displays Chinese characters correctly, but in the Message building, it's not working.

Please help, thanks!

2 comments

P.S I've also tried  -Dconsole.encoding=GBK, -Dconsole.encoding=GB2312, no good

Maybe -Dconsole.encoding doesn't affect message output? 

I'm wondering how to set its encoding then

0

Please sign in to leave a comment.